Please note: This forum is now closed. All the support related enquiries should be reported on wordpress support forum for jigoshop plugin – thanks, Jigoshop Team

Login error messages not showing

Angela's Avatar

Angela

19 Jan, 2013 02:08 AM

When logging in via the My Account page, if any wrong data is submitted, the page just refreshes. An error message explaining what was incorrect does NOT show up. Isn't it supposed to explain to the user what went wrong? (i.e. incorrect password or invalid username?).

I thought at one point that it was showing error messages, so it seems to be that this might be a new bug since the upgrade to 1.4.9.

The lack of an error message is confusing the heck out of my customers and causing them to get themselves locked out of their accounts due to excessive login attempts.

I'm running Jigoshop on WPMU, as a side note.

  1. Support Staff 2 Posted by chriscct7 on 19 Jan, 2013 12:03 PM

    chriscct7's Avatar

    A URL would be helpful as well as your Jigoshop System Info

  2. 3 Posted by Angela on 19 Jan, 2013 03:46 PM

    Angela's Avatar

    Apologies...

    URL: http://hellocuteness.com/shop/my-account/

    SYSTEM INFO:

    ### Begin System Info ###
    
    Multi-site:               Yes
    
    SITE_URL:                 http://hellocuteness.com
    HOME_URL:                 http://hellocuteness.com
    
    Jigoshop Version:         1.4.9
    WordPress Version:        3.5
    
    Platform:                 Windows 
    Browser Name:             Internet Explorer  
    Browser Version:          9.0 
    User Agent String:        Mozilla/5.0 (compatible; MSIE 9. 
                                  0; Windows NT 6.0; WOW64; Triden
                                  t/5.0)
    
    PHP Version:              5.3.8
    MySQL Version:            5.1.66-cll
    Web Server Info:          Apache
    
    PHP Memory Limit:         256M
    PHP Post Max Size:        128M
    
    WP_DEBUG:                 Disabled
    
    WP Table Prefix:          Length: 3 Status: Acceptable
    
    Show On Front:            page
    Page On Front:            413
    Page For Posts:           0
    
    Session:                  Enabled
    Session Name:             PHPSESSID
    Cookie Path:              /
    Save Path:                /tmp
    Use Cookies:              On
    Use Only Cookies:         On
    
    UPLOAD_MAX_FILESIZE:      128MB
    POST_MAX_SIZE:            128MB
    WordPress Memory Limit:   64MB
    WP_DEBUG:                 Off
    DISPLAY ERRORS:           On (1)
    FSOCKOPEN:                Your server supports fsockopen.
    
    ACTIVE PLUGINS:
    
    Category Grid View Gallery: 2.3.1
    FixImageMargins: 0.1.0
    Genesis Connect for Jigoshop: 1.0.2
    Genesis Featured Widget Amplified: 0.8.1
    Gravity Forms: 1.6.11
    Jetpack by WordPress.com: 2.1.1
    Jigoshop: 1.4.9
    Theme My Login: 6.2.3
    WP Super FAQ: 0.5.6
    
    CURRENT THEME:
    
    Hello, Cuteness! Theme: 1.0
    
    ### End System Info ###
    
  3. Support Staff 4 Posted by chriscct7 on 20 Jan, 2013 01:23 PM

    chriscct7's Avatar

    This is not a bug with Jigoshop. All Jigoshop does is call the standard WordPress login. Rather this is a bug it seems with the Theme My Login plugin you are using.

  4. 5 Posted by Angela on 20 Jan, 2013 03:26 PM

    Angela's Avatar

    Thank you Chris. I just tried out the demo (http://try.jigoshop.com/?page_id=7) and I do see that the error messages are working just fine. I really love the Theme My Login plugin as I do not like for my customers to see the default WordPress login screens. Perhaps this is something that can be suggested as a feature for future Jigoshop versions? The ability to theme the default login screens to match?

    I'm going to put in a support ticket with the TML plugin author as well, just to see if he can suggest any work arounds for the error messages not showing.

    Have a nice day!

  5. Support Staff 6 Posted by chriscct7 on 20 Jan, 2013 09:40 PM

    chriscct7's Avatar

    We can't add those options because every theme looks different. Those options should be present in the theme really.

    This is really more a bug in TML.

    -Chris

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac