Please note: This forum is now closed. All the support related enquiries should be reported on wordpress support forum for jigoshop plugin – thanks, Jigoshop Team

Cross-sell images not displaying / Up-sells images display in limited quantity of 2

jrfehringer's Avatar

jrfehringer

03 May, 2012 06:53 AM

I purchased your Up-Sell/Cross-Sell Extension and, when activated I am unable to get the cross-sells to display. I moved over to the up-sells to try them out and entered the 4 images and I am only getting 2 to display regardless of how many images are selected in the admin. When I refresh the page, the same 2 images either show up in a different display order or I get a new combination of the selected images as though there was a random filter on the display. Is 2 the limit of images that can display at one time? Why won't the cross-sells show.?

Here's a couple of links:

http://johnfehringer.com/gallery/morning_glory/
http://johnfehringer.com/gallery/wild-blue/

Realize you are seeing only the up-sells even though there are images placed in both cross-sells and up-sells.

I read back in the forums that there was an issue with this plug-in going back to Aug of 2011. Was that same issue fixed and this is a new bug?
http://forum.jigoshop.com/discussions/problems/2247-setting-the-num...
http://forum.jigoshop.com/discussions/problems/142-up-sells-cross-s...

  1. 1 Posted by jrfehringer on 07 May, 2012 12:32 AM

    jrfehringer's Avatar

    Anyone have any thoughts on this?

    I can't get the cross-sells to display and the up-sells are limited to 2 images. Has anyone figured out a fix for this?

  2. Support Staff 2 Posted by ivica on 23 May, 2012 05:48 PM

    ivica's Avatar

    Hi! I advised developers to take look on this, we will let you know the feedback, when we receive it. Thank you for your questions!

  3. Support Staff 3 Posted by Jeff on 24 May, 2012 01:20 AM

    Jeff's Avatar

    Cross sells appear on the cart only. There will be 2 only, randomly selected if there are more available.

    Looks like something may have changed for up sells though as this did work at one point.

    For Jigoshop version 1.2.2 in the file 'jigoshop_template_functions.php' in the main plugin directory, find line # 693 and paste the following in:

            $per_page = null;   // reset for cross sells if enabled
            $columns = null;
    

    Then, the bit of code that Matt provided in this post # 2:

    http://forum.jigoshop.com/discussions/problems/2247-setting-the-num...

    ... when pasted into your theme's functions.php should work as expected.

    We'll have the fix in for Jjigoshop 1.2.3.

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac