Please note: This forum is now closed. All the support related enquiries should be reported on wordpress support forum for jigoshop plugin – thanks, Jigoshop Team

Issues with Variable Product Images

jrkellew's Avatar

jrkellew

08 Nov, 2011 02:54 AM

First off, I'm not sure these days which forum I should be posting in. I am a Jigoshop club member but this forum seems to receive much more activity so tell me if I should be posting in the premium forum instead of here.

I am using variable products on a project I am working on at the moment. I have added the attributes and added the two variations I need and they are both appearing in the product page & can be selected with no problem. However, when i try and upload an image, I navigate to the image, upload it, click to insert it into the post and the wp media uploader stalls & no image is uploaded.

This happened a couple of times when I tested the variations out on my locals server and I can't remember what I did to get the images attached but nothing I try now seems to work. Does anyone have any ideas or am I going about this completely wrong?

  1. 1 Posted by Matt on 08 Nov, 2011 05:30 PM

    Matt's Avatar

    We certainly answer premium tickets faster than these forums. We're going to start changing how we address these forums too. You'll see activity dying down from me quite a bit :p

    After you upload an image, click on "Use as featured image" rather than "Insert into post". That should do it.

  2. 2 Posted by jrkellew on 08 Nov, 2011 06:04 PM

    jrkellew's Avatar

    Okay great...I'll put a ticket in in the future.

    Use as featured image doesn't seem to work either (I meant to include that in the original post). When I click "Use as featured image" The thumb for the main product featured image updates in the admin screen but no thumb appears for the variation. After updating the product, the main featured image thumb returns and their is still no attached thumbs for the variations.

    Should I only be including variation images and no other product images?

  3. 3 Posted by Matt on 08 Nov, 2011 06:21 PM

    Matt's Avatar

    I suppose it's a bit confusing isn't it?

    When you click "Use as featured image" the main featured image will appear to update. But if you refresh the product edit page, you'll see the variation image is updated.

    Is this not the case?

    Also, you can have multiple product images aside from variation images, that is fine.

  4. 4 Posted by jrkellew on 08 Nov, 2011 07:23 PM

    jrkellew's Avatar

    Unfortunately this isn't the case for me.

    The page refreshes but there is no image for the variation.

    I just tried a new test product to see if it would work if I did not add any other product images and ran into this issue which I had experienced earlier too. After choosing an image to upload, I get taken to the usual area to edit the image details but I only have the option to "Insert into post", there is no option to "Use as Featured Image". If I click insert into post, I get that blank screen I attached earlier.

    If I then hit publish or save draft, there is no variation image but if I go ahead and upload another, I then get the option to set it as a featured image, but this featured image doesn't display.

    I am completely stumped...I just tried again on my local server machine and the thumbs worked fine using the insert into post method.

    Maybe I should try re-installing the plugin? Would this destroy any data or settings? I am also happy to let someone into the backend to take a look if they want.

  5. 5 Posted by Matt on 08 Nov, 2011 07:45 PM

    Matt's Avatar

    Using Chrome, hit F12 when adding an image and see what the Console tab says.

  6. 6 Posted by jrkellew on 08 Nov, 2011 08:04 PM

    jrkellew's Avatar

    At the blank screen after inserting I get this error in the console:

    post.php:802Uncaught TypeError: Cannot call method 'replace' of undefined
    window.send_to_cproductpost.php:802
    (anonymous function)

  7. 7 Posted by Matt on 08 Nov, 2011 08:32 PM

    Matt's Avatar

    No idea. Use a different browser? Disable all plugins except Jigoshop?

  8. 8 Posted by jrkellew on 08 Nov, 2011 09:11 PM

    jrkellew's Avatar

    Same result with Firefox and Jigoshop is the only Plugin I currently have activated.

    The site is set up exactly the same on my local server and it is not an issue.

    This is why I was thinking a re-install of Jigo could help as I have no idea what coule be causing this.

  9. 9 Posted by Matt on 08 Nov, 2011 09:14 PM

    Matt's Avatar

    Give it a try I suppose.

  10. 10 Posted by Julian Valencia on 14 Nov, 2011 04:55 AM

    Julian Valencia's Avatar

    This is happening to me too, I get this error when I see the blank media window:

    Error: imgclass is undefined
    Archivo de origen: /wp-admin/post.php?post=358&action=edit
    Línea: 1103

    an that line says:
    imgid = parseInt(imgclass.replace(/\D/g, ''), 10);

    at firt the variations images was working fine, but suddenly it began to show the blank page inside the media window.

    I deactivated all the plugins but the problem keeps happening

  11. 11 Posted by Julian Valencia on 14 Nov, 2011 05:25 AM

    Julian Valencia's Avatar

    some testing results:

    I deleted my database and started a new wordpress-jigoshop, with the same wordpress and plugin files I was using. And then the "insert into post" button worked again for variation product images.

    After that, I imported my original website's database again and tested the "insert into post" button but then the problem of the "blank media window and no image to variation" start happening again.

    I guess this began to happen when my client start to move the database and created attributes, products, inserting new media etc. I think that because there are not other movements that my client can do in the site. and how you can see by this experiment the problem was fixed only when starting a new wordpress.

    the problem is not in the theme because I activated "twetyten" and the problem didn't fix

    I think this is not a third plugin's incompatibility problem because I deactivated all plugins for testing

  12. 12 Posted by Matt on 14 Nov, 2011 03:12 PM

    Matt's Avatar

    Julian,

    You should use a "Use as featured image" rather than "Insert into post" button.

    Try these steps:

    1. Create new product
    2. Select "Variable" product type
    3. Publish product
    4. Add attribute
    5. Update product
    6. Add variation and try doing variation images.
  13. 13 Posted by jrkellew on 14 Nov, 2011 03:35 PM

    jrkellew's Avatar

    Hi Julien,

    I now have it working, thanks to some help from Matt but there are a couple more steps I have to implement to get the image displaying.

    At step 6 that Matt listed above, add the variations but do not add the images yet. Once you have all your variations in place, "Update" or "Save Draft". I found if I did not save or update, when adding an image, I only got the option to "Insert into Post" and not "Use as featured Image".

    After saving/updating, add your images and for each image, hit "Use as Featured Image", close the image uploader and then refresh the edit page without saving. Now your Variable image will be in place and you can update or repeat for the other variations.

    I am not sure what is causing this issue as I was using "Insert into Post" on my local version of the site with no issues. I also have no other plugins and was trying this out after a clean WordPress and Jigoshop install.

    I have it working but it is still a little confusing for the client as there are so many potential pitfalls.

  14. 14 Posted by Matt on 14 Nov, 2011 03:37 PM

    Matt's Avatar

    What steps were you taking for it to show the white image? We had another user report this issue. What he did was he selected "Variable" product type after assigning attributes.

  15. 15 Posted by jrkellew on 14 Nov, 2011 04:01 PM

    jrkellew's Avatar

    I am not sure if Julien's experience is the same but it does not matter to me whether I assign the attributes before or after selecting a "Variable" product.

    If I do not save or update after adding a configuration, when uploading an image for that configuration, I only get the option to "Insert into Post" or "Delete". If I click "Insert into Post" I get the blank white screen.

    However, if I add the configuration & save/update the product before uploading the image, I get the option to "use as featured image".

  16. 16 Posted by Matt on 14 Nov, 2011 04:25 PM

    Matt's Avatar

    Ah okay, thanks.

    I suppose we should change the warning message:

    You must save your product attributes in the "Product Data" panel first & mark them for variation to make them available for selection.
    

    To include featured images and saving after adding a variation. Would that help? Though I'll bring it to our dev's attention and we'll see what they say. Perhaps there is a code fix they can implement.

  17. 17 Posted by jrkellew on 14 Nov, 2011 04:39 PM

    jrkellew's Avatar

    Yeah that would be great if it is not something the Dev's can fix.

    I's also suggest updating the guide on using configurable products (link below) as this was what I initially worked from and couldn't understand why the variation images were not displaying.

    http://jigoshop.com/user-guide/setting-up-your-store/setting-up-con...

  18. 18 Posted by Matt on 14 Nov, 2011 05:05 PM

    Matt's Avatar

    Thank you, I've included a note to that guide as well as the KB article.

  19. 19 Posted by Julian Valencia on 14 Nov, 2011 06:41 PM

    Julian Valencia's Avatar

    Hello! thank you for the quick answer

    I finally could assign images to variations thanks to the Matt and jrkellew answers

    The steps I follow was these:

    1. Create new product
    2. Select "Variable" product type
    3. Publish product
    4. Add attribute and tick variation checkbox
    5. Update product
    6. Add variation
    7. Select variation image but clicking "use as featured image" (after that you'll see no image in the variation and the image you selected will be assigned as featured product image)
    8. Don't save after clicking "use as featured image", instead of that refresh the page.

    Now the image shows fine for the variation but you have to go and select the right featured image for the product.

    I'm glad I can fix this by now, but the steps are getting harder and less intuitive for clients, also in a new installation this isn't happening, so.. I think this get damaged when somebody starts adding attributes, products or makes some other movements on the database.

  20. 20 Posted by Marvin Cruz on 26 Jan, 2012 10:38 AM

    Marvin Cruz's Avatar

    None of the steps mentioned above worked for my case. Any updates or patches for this known bug?

  21. 21 Posted by akari on 28 Jan, 2012 01:37 PM

    akari's Avatar

    Same as Marvin.
    Follow step by step but when adding image never appear "use as featured image".
    What can I do?

  22. 22 Posted by Jen on 12 Feb, 2012 08:20 PM

    Jen's Avatar

    I am also having the same problem

  23. 23 Posted by Matt on 12 Feb, 2012 08:52 PM

    Matt's Avatar

    Read the FAQ,

    I don't see a "Set featured image" anywhere!

    http://forum.jigoshop.com/kb/getting-started/faq

  24. 24 Posted by bventure on 09 Apr, 2012 04:26 PM

    bventure's Avatar

    I'm in the same boat here. Everything was going great then I got a note from my client that she wasn't seeing the image change when she selected different variations. Went in to take look, thought I'd recreate some variations, and found I could no longer add variation images. Tried different themes, disabled plugins, different browsers, created new products and I've run through all the steps in this forum many times.

    I get the blank screen after hitting "insert into post", and I can't seem to get the option to use as featured image. This all worked fine on initial set up.

    EDIT: Solved for me. I was editing in HTML mode, not the wysiwyg. Switched back to Visual mode and "insert into post" worked again.

  25. 25 Posted by MarkF on 19 Apr, 2012 09:09 PM

    MarkF's Avatar

    Hi all,

    I'm having this problem too!
    Tried everything in this thread but still I only see "Insert into Post" and then get the white dialogue box of death! :)

    I have the following line in my theme's functions.php file in the setup function -

    add_theme_support('post-thumbnails', array('post', 'product', 'slider-item'));

    I really need this working asap as about to handover site to client!
    Help please!

    Thanks
    Mark :)

  26. 26 Posted by MarkF on 23 Apr, 2012 10:07 PM

    MarkF's Avatar

    bump

    Anyone?

    Thanks! :)

  27. 27 Posted by MarkF on 26 Apr, 2012 09:11 PM

    MarkF's Avatar

    I'm stuck on this and the client is waiting - ouch!

    Any help greatly appreciated!

    Thanks
    Mark :)

  28. 28 Posted by Philo on 06 May, 2012 06:22 PM

    Philo's Avatar

    Hello - I was having this same exact problem. Could not insert an image with a variation - everything was working fine then BAM it wouldn't work. I did not have the option to "use as featured image".

    What worked for me was to click on "File URL" button then click on "insert into post"

    Give it a shot.

    Philo

  29. 29 Posted by MarkF on 06 May, 2012 09:27 PM

    MarkF's Avatar

    oh man - thank you that works a treat!!
    You don't know how much time I've spent on this over the last two weeks!

    thank you again!!

    Mark :)

  30. 30 Posted by Julian Valencia on 07 May, 2012 12:15 PM

    Julian Valencia's Avatar

    El 06/05/2012 04:27 p.m., MarkF escribió:

Comments are closed, but you can start a new discussion.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac